Integrate Podman in Java integration test with TestContainer
Hi, In order to use TestContainer framework, I need to use the new REST API. Does io.podman linux daemon provide the service ? Regards.
No it does not ... I am coincidentally working the project now to run their test suite. There are a number of issues being found so far, most of which is how their test suite is setup to communicate with the docker endpoint and more specifically the use of docker-java. I'm trying to investigate how I can influence that. On Thu, 2020-03-05 at 19:51 +0000, sylvain.bonnemaison@ti-mm.com wrote:
Hi, In order to use TestContainer framework, I need to use the new REST API. Does io.podman linux daemon provide the service ? Regards. _______________________________________________ Podman mailing list -- podman@lists.podman.io To unsubscribe send an email to podman-leave@lists.podman.io
There is a docker-java branch : https://github.com/testcontainers/testcontainers-java/pull/2297 This might be the answer to the question !
Based on a quick look, I dont think so but will investigate more. On Thu, 2020-03-05 at 21:09 +0000, sylvain.bonnemaison@ti-mm.com wrote:
There is a docker-java branch : https://github.com/testcontainers/testcontainers-java/pull/2297 This might be the answer to the question ! _______________________________________________ Podman mailing list -- podman@lists.podman.io To unsubscribe send an email to podman-leave@lists.podman.io
The last libpod version 1.8.0 provide docker compatible rest api with command "podman system service" https://github.com/containers/libpod/releases/tag/v1.8.0
Podmab 1.9 provide a docker like REST API service. Running this service as a linux daemon using systemctl limit service access to root account. How to let others user accounts have access to the prodman REST API? Is there a specific podman configuration? Thanks
On 2020-04-26 20:51, sylvain.bonnemaison@ti-mm.com wrote:
Podmab 1.9 provide a docker like REST API service. Running this service as a linux daemon using systemctl limit service access to root account. How to let others user accounts have access to the prodman REST API? Is there a specific podman configuration? Thanks _______________________________________________ Podman mailing list -- podman@lists.podman.io To unsubscribe send an email to podman-leave@lists.podman.io
We'd recommend adding the Podman service to the systemd user session of each user that will be using rootless Podman. The per-user service requirement is annoying, but consistent with our security model (ensures Podman does not get involved with user authentication, which is a main goal of the new API). If your users do not have a systemd user session, the `podman system service --timeout=0` command can be manually run as the user. Thanks, Matt Heon
Running Podman REST API with command : "systemctl --user start podman", and defining DOCKER_HOST system environment variable with "unix:///var/run/user/1000/podman/podman.sock", TestContainers generate this error: "java.io.IOException: [111] Connection refused". Is it Docker API compatibility problem? Anything else ?
Reboot Linux system make TestContainers works better. Now it fails loading container image. Starting TestContainers twice make the previous problem happened. Is there a way to close podman.socket using bash command? (without Linux reboot))
On 2020-05-26 21:35, sylvain.bonnemaison@ti-mm.com wrote:
Reboot Linux system make TestContainers works better. Now it fails loading container image. Starting TestContainers twice make the previous problem happened. Is there a way to close podman.socket using bash command? (without Linux reboot)) _______________________________________________ Podman mailing list -- podman@lists.podman.io To unsubscribe send an email to podman-leave@lists.podman.io
Does `systemctl --user restart podman.service` help? Podman is not directly managing the socket here, since we're socket activated by systemd. Thanks, Matt Heon
No. I get following journal trace: ``` mai 27 23:12:41 lt003 systemd[1062]: podman.service: Found left-over process 8034 (podman pause) in control group while starting unit. Ignoring. mai 27 23:12:41 lt003 systemd[1062]: This usually indicates unclean termination of a previous run, or service implementation mai 27 23:12:41 lt003 podman[17220]: Error: unable to create socket unix:/run/user/1000/podman/podman.sock: listen unix /run/user/1000/podman/podman.sock: bind: address already in use mai 27 23:12:41 lt003 systemd[1062]: podman.service: Main process exited, code=exited, status=125/n/a -- The process' exit code is 'exited' and its exit status is 125. mai 27 23:12:41 lt003 systemd[1062]: podman.service: Failed with result 'exit-code'. mai 27 23:12:41 lt003 systemd[1062]: Failed to start Podman API Service. ``` Sylvain
participants (3)
-
Brent Baude -
Matt Heon -
sylvain.bonnemaison@ti-mm.com