I think you could use 'RequiresMountsFor=...' in your unit, see https://www.freedesktop.org/software/systemd/man/systemd.unit.html#RequiresM... On Tue, Sep 6, 2022 at 7:56 PM Robin Lee Powell <robinleepowell@gmail.com> wrote:
On Mon, Sep 05, 2022 at 11:56:11AM +0100, lejeczek via Podman wrote:
Hi guys.
Would you know how, if possible at all, to delay an autostart of a container?
My specific scenario is such in which containers- auto-started by systemd - reside under a net mount-point which is mounted at later stage by ha/pcs(so containers fail to start @boot) I'd hope that it's doable without extra & "external" scripts/tools.
The way I'd handle that is with ExecStartPre in systemd; have it run a script that checks occassionally to see if the thing it needs is running. _______________________________________________ Podman mailing list -- podman@lists.podman.io To unsubscribe send an email to podman-leave@lists.podman.io