No, the right side of the colon was empty. 

I'm using your commit that added the AllPlatforms bool to the BuildOptions, but I was getting this same behavior with the latest tagged release.

I was able to use Commit() successfully (to show that builds were working in the env at one point),  but I am getting the same build errors that I was when I use the BuildOpts and Store from your attachment (using your dockerfile). 


On Fri, Oct 1, 2021 at 2:35 PM Nalin Dahyabhai <> wrote:
On Fri, Oct 01, 2021 at 02:21:20PM -0400, Alex Flom wrote:
> Looks like it is successfully running the FROM step in the containerfile
> and then fails on the second step. I've tried changing the second step to
> various actions with the same result. I've also verified that I am able to
> pull that image on the host.
> Here is the output at the failure:
> [linux/s390x] STEP 1/5: FROM
> [linux/amd64] STEP 1/5: FROM
> [linux/arm64] STEP 1/5: FROM
> [linux/ppc64le] STEP 1/5: FROM
> [linux/s390x] STEP 2/5: ENTRYPOINT ["/bin/opm"]
> [linux/arm64] STEP 2/5: ENTRYPOINT ["/bin/opm"]
> [linux/ppc64le] STEP 2/5: ENTRYPOINT ["/bin/opm"]
> [linux/amd64] STEP 2/5: ENTRYPOINT ["/bin/opm"]
> time="2021-10-01T18:16:56Z" level=error msg="4 errors occurred:\n\t* error
> building at STEP \"ENTRYPOINT /bin/opm\":

Was there any detail about why each of them failed after that last ":"?
BTW, which version of the library are you using?  I'm attaching a sample
that seems to work when I build using the current version (v1.23.1).




Alex Flom

Solution Architect

Red Hat

Virginia Beach, VA    
M: 970.443.0191